summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-02 14:59:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-02 14:59:17 +0300
commitec6ee50f716e883c6841c93f5b11ccef9ce711aa (patch)
tree349af5b356baa6a67bc97535e8d48cc042bccbf0 /dev-python/jupyter_packaging
parentdev-python/python-libevdev: drop 0.10 (diff)
downloadgentoo-ec6ee50f716e883c6841c93f5b11ccef9ce711aa.tar.gz
gentoo-ec6ee50f716e883c6841c93f5b11ccef9ce711aa.tar.bz2
gentoo-ec6ee50f716e883c6841c93f5b11ccef9ce711aa.zip
dev-python/jupyter_packaging: drop 0.12.0-r1, 0.12.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_packaging')
-rw-r--r--dev-python/jupyter_packaging/Manifest2
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.12.0-r1.ebuild49
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.12.1.ebuild39
3 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index 319227ba2602..5f854383d2be 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1,3 +1 @@
-DIST jupyter_packaging-0.12.0.tar.gz 25258 BLAKE2B 1e8897297e6d1e592a5e3d934f850a9fadc27b7fd97484c6ef3dda9ae5d6da0c48116846e0f3fe7757c3c4794a7a8e2e3eaa69b3fe3a68f73cc952707fa27ec1 SHA512 2a34b64a34f6931b7ba0578a9c1c270285a970043136f65c4a7afbc8e9a5e70feb1bffdc00f682d1fa49fe1f5f91bd3a093437f0f05232e6a57c97eda7f1fc29
-DIST jupyter_packaging-0.12.1.tar.gz 27813 BLAKE2B 8b36d672bfd30734239486fc048f4f6f591511ec4009a9707a44ee12e71e06edc4944ff72e6e63206731705aca092efaa7ef185cf0c216ebfbe4f940ca3d7a27 SHA512 d1216c6b4b65f7e2706bf28d19110e3f8bc6c01d5821d3c3b6bdbbfeb6ebda40f893ef596bf67d87d157e9db436acc751640ea518880063eb387dda8cd78ef15
DIST jupyter_packaging-0.12.2.tar.gz 27990 BLAKE2B 0cd07fa760fe0bd4529e8430bd52863034cc4c78d8f906f55530a6825c496b8a1bf2fff76da3f4e963ee43c80fc19347edbaf20d16fbfe51584b040b0ab4d3ed SHA512 f4167c7beb3188d2e4b0fa8601fb8cdede8b20dc8c16e0bccbcf9e317e75e24ea1469a9d904bb35b2d81dec351caf49526ef35e5d91460a099a8e4ed6974e1b1
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.12.0-r1.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.12.0-r1.ebuild
deleted file mode 100644
index 424417f76895..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.12.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/setuptools-60.2.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # require Internet
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-)
-
-src_prepare() {
- # https://github.com/jupyter/jupyter-packaging/pull/135
- cat >> setup.cfg <<-EOF
- [options.packages.find]
- exclude = tests
- EOF
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.12.1.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.12.1.ebuild
deleted file mode 100644
index c7bae7e74312..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.12.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/setuptools-60.2.0[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/build[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # require Internet
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-)