summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 15:59:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:10 +0100
commit8969cf80efa4fc7a8a47f6948409db9a61bc53c4 (patch)
tree1b5f67fbb3990f6bce40c4a8a5ee69b923155293 /dev-python/jupyterlab_server
parentdev-python/emoji: Bump to 2.2.0 (diff)
downloadgentoo-8969cf80efa4fc7a8a47f6948409db9a61bc53c4.tar.gz
gentoo-8969cf80efa4fc7a8a47f6948409db9a61bc53c4.tar.bz2
gentoo-8969cf80efa4fc7a8a47f6948409db9a61bc53c4.zip
dev-python/jupyterlab_server: Bump to 2.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyterlab_server')
-rw-r--r--dev-python/jupyterlab_server/Manifest1
-rw-r--r--dev-python/jupyterlab_server/jupyterlab_server-2.16.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/jupyterlab_server/Manifest b/dev-python/jupyterlab_server/Manifest
index bcdd1617e2b3..618ddcc8f50e 100644
--- a/dev-python/jupyterlab_server/Manifest
+++ b/dev-python/jupyterlab_server/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab_server-2.16.0.tar.gz 62546 BLAKE2B ce8c1d8aa906d61ebdfccbcdd851a26df09c39a4dbdbe84297889b6a28960eb7616de049b6a6cab6188ae4392535f1e45f60f4699b52ce9eea4071c9b89d7745 SHA512 13df24cf3b77d74b64cbacb6d0d9f385e2e09adc77dc223a0ebaa56585c29f7fcf3f91c0091c4d3354dc0059ba1126cf813c74119f3c8f6a6244b9d1f0ab43e2
DIST jupyterlab_server-2.16.1.tar.gz 64634 BLAKE2B 05d71b229b9e226bcae409028ff97fa6313662b506171ee5fcb3d8a0cb29c6339f5a54ce91a31b251e969d1418d1a6ede61ccefb1be5412f35bbe51d34378fcf SHA512 3841463b56adcca2d65a9943e04c084fef47b208b46012c9e01a3f91d58058d0bc8e0e97dd1c794ebc7963fc7106f4965524ba293268bb4e7a2e41158a7c54cf
+DIST jupyterlab_server-2.16.2.tar.gz 64742 BLAKE2B 73b3c1f7080134e30d9e0d38af9ef8f5e4161a11d1a08e6d638ffdccd4def0f7fb7b16c8ef1e9191542e27267f2e47a8a21bf53dc103c4c79c32b9722252095d SHA512 d7229343994d78ae2ff0d5cdfa2670f23f221ab2bfd009351c5a8a5611b0dd04c47eb5c899a4155712322f3c3f74fcbcbb3a687cdc737382bc3eabca6d69c527
diff --git a/dev-python/jupyterlab_server/jupyterlab_server-2.16.2.ebuild b/dev-python/jupyterlab_server/jupyterlab_server-2.16.2.ebuild
new file mode 100644
index 000000000000..a3afe0f0c7c4
--- /dev/null
+++ b/dev-python/jupyterlab_server/jupyterlab_server-2.16.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/json5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.8[${PYTHON_USEDEP}]
+ <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.14.2[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.15[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst_parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}