summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 13:14:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 13:14:22 +0200
commitd228931d62ee2cd5fc3bcf2c4148277bb50981e9 (patch)
treed9e025bfbe0088d57381bafe07aceb58e3b46ce3 /dev-python/kafka-python/kafka-python-1.4.7.ebuild
parentdev-python/google-api-python-client: Eliminate unittest2 (diff)
downloadgentoo-d228931d62ee2cd5fc3bcf2c4148277bb50981e9.tar.gz
gentoo-d228931d62ee2cd5fc3bcf2c4148277bb50981e9.tar.bz2
gentoo-d228931d62ee2cd5fc3bcf2c4148277bb50981e9.zip
dev-python/kafka-python: Correct test dependencies
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kafka-python/kafka-python-1.4.7.ebuild')
-rw-r--r--dev-python/kafka-python/kafka-python-1.4.7.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-python/kafka-python/kafka-python-1.4.7.ebuild b/dev-python/kafka-python/kafka-python-1.4.7.ebuild
index 36adc8405d2e..0a7e9046e9de 100644
--- a/dev-python/kafka-python/kafka-python-1.4.7.ebuild
+++ b/dev-python/kafka-python/kafka-python-1.4.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="Kafka protocol support in Python"
@@ -13,17 +13,12 @@ SRC_URI="https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="snappy test"
-RESTRICT="!test? ( test )"
+IUSE="snappy"
RDEPEND="snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )"
BDEPEND="
test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
)"
-python_test() {
- unit2 -v || die "tests failed with ${EPYTHON}"
-}
+distutils_enable_tests pytest