summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-31 02:01:52 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-31 02:01:52 -0700
commitf93be8b63efd69620d36c1ad6ce0d275751b5d4d (patch)
tree0a444c6f60bcaedd0c09dbf2fa8351f9c3037116 /dev-python/kconfiglib/kconfiglib-14.1.0.ebuild
parentmedia-video/mkvtoolnix: version bump to 43.0.0 (diff)
downloadgentoo-f93be8b63efd69620d36c1ad6ce0d275751b5d4d.tar.gz
gentoo-f93be8b63efd69620d36c1ad6ce0d275751b5d4d.tar.bz2
gentoo-f93be8b63efd69620d36c1ad6ce0d275751b5d4d.zip
dev-python/kconfiglib: version bump to 14.1.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/kconfiglib/kconfiglib-14.1.0.ebuild')
-rw-r--r--dev-python/kconfiglib/kconfiglib-14.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/kconfiglib/kconfiglib-14.1.0.ebuild b/dev-python/kconfiglib/kconfiglib-14.1.0.ebuild
new file mode 100644
index 000000000000..52b0349ecfe9
--- /dev/null
+++ b/dev-python/kconfiglib/kconfiglib-14.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="A flexible Python Kconfig implementation"
+HOMEPAGE="https://github.com/ulfalizer/Kconfiglib https://pypi.org/project/kconfiglib/"
+SRC_URI="https://github.com/ulfalizer/Kconfiglib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarballs don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P/k/K}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # hacks to run tests
+ mkdir Kconfiglib || die
+ ln -s ../tests Kconfiglib || die
+ # don't run kernel Kconfig compat tests
+ sed -i 's/run_compatibility_tests()$/#\0/' testsuite.py || die
+}
+
+python_test() {
+ "${PYTHON}" testsuite.py || die "tests failed with ${EPYTHON}"
+}