summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-02 23:38:12 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-02 23:39:06 -0700
commit6e1989ebfdce8227d13aecb90c506211a6b9ff85 (patch)
tree6736591799ff243d8aef6c838b2ef20dc6ffb9da /dev-python/kconfiglib
parentvirtual/linux-sources: *-bin too (diff)
downloadgentoo-6e1989ebfdce8227d13aecb90c506211a6b9ff85.tar.gz
gentoo-6e1989ebfdce8227d13aecb90c506211a6b9ff85.tar.bz2
gentoo-6e1989ebfdce8227d13aecb90c506211a6b9ff85.zip
dev-python/kconfiglib: version bump to 13.7.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/kconfiglib')
-rw-r--r--dev-python/kconfiglib/Manifest1
-rw-r--r--dev-python/kconfiglib/kconfiglib-13.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/kconfiglib/Manifest b/dev-python/kconfiglib/Manifest
index db8807dabaad..1d6598823030 100644
--- a/dev-python/kconfiglib/Manifest
+++ b/dev-python/kconfiglib/Manifest
@@ -1,2 +1,3 @@
DIST kconfiglib-12.12.1.tar.gz 181307 BLAKE2B d256148bd6bf01f7951c78751604eae1be4c2fc156b815bdb570e6fcf185c2f5c97259f6ce0ed275104234ff7180afa2000a81feb281e745a8a0c4db162f57b9 SHA512 49e8746e6c83a93b7500130b21b864346ab8106c0c161de0ec62b3efff794080e734d34d88cd9c816c0d6514465729fbc3a4334fcc9c0a68f17c1688bb210325
DIST kconfiglib-13.2.0.tar.gz 181115 BLAKE2B 81aeab65c4d7008dad33d508eb2be5ed53187943c1ec5112a87a47a5f9bb661c521b0d61a3da63da3233f168d62ab6bb5cdf6e3702e53f960159b7ca13c8a0cf SHA512 9d8c76014aa7faa93af216849859eca9bfdc0d4cd3e030e47b72acfdd4981ac1581747adf91bca58a4e8d86b151988309f36c3f94a1ebb216a1412fd004fafd2
+DIST kconfiglib-13.7.0.tar.gz 182782 BLAKE2B 976a8e4e377933e42dc45c79598a175d302d34f48bfadd764c0cbfa2ddd4e15ae6ba22467c50d41657abbaa1f4495c556fb4c1deb9c96e1119a7bdd6ae8a3378 SHA512 0376b2c4e68b7ce4f105f52a3b4793a23cb844dbd9ab183abbdd79e2f7958e3be372024ce82295902af974f010c73c4ac97a4147bdac8ee9b52900bc15b8bb6f
diff --git a/dev-python/kconfiglib/kconfiglib-13.7.0.ebuild b/dev-python/kconfiglib/kconfiglib-13.7.0.ebuild
new file mode 100644
index 000000000000..0adf3b139b7c
--- /dev/null
+++ b/dev-python/kconfiglib/kconfiglib-13.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} pypy3 )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="A flexible Python Kconfig implementation"
+HOMEPAGE="https://github.com/ulfalizer/Kconfiglib https://pypi.org/project/kconfiglib/"
+SRC_URI="https://github.com/ulfalizer/Kconfiglib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarballs don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+
+S=${WORKDIR}/${P/k/K}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # hacks to run tests
+ mkdir Kconfiglib || die
+ ln -s ../tests Kconfiglib || die
+ # don't run kernel Kconfig compat tests
+ sed -i 's/run_compatibility_tests()$/#\0/' testsuite.py || die
+}
+
+python_test() {
+ "${PYTHON}" testsuite.py || die "tests failed with ${EPYTHON}"
+}