summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-28 22:24:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-28 23:01:59 +0100
commitdab61ce8bba14f104289586ed1d267fc43d390e1 (patch)
treef4e05268438f9086370912cc288f855febb4774e /dev-python/keyring/keyring-23.4.0.ebuild
parentdev-python/fakeredis: Bump to 1.7.0 (diff)
downloadgentoo-dab61ce8bba14f104289586ed1d267fc43d390e1.tar.gz
gentoo-dab61ce8bba14f104289586ed1d267fc43d390e1.tar.bz2
gentoo-dab61ce8bba14f104289586ed1d267fc43d390e1.zip
dev-python/keyring: Bump to 23.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring/keyring-23.4.0.ebuild')
-rw-r--r--dev-python/keyring/keyring-23.4.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-23.4.0.ebuild b/dev-python/keyring/keyring-23.4.0.ebuild
new file mode 100644
index 000000000000..dced4d33c0b0
--- /dev/null
+++ b/dev-python/keyring/keyring-23.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/jaraco-packaging \
+ dev-python/rst-linker
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)