summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-07-15 11:02:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-07-15 11:02:14 -0500
commitae4baf101dae1c0a3acae6abe898287b4ab7f3e9 (patch)
treed6ffbda19031c591d705abbbafae88329ae5ba1c /dev-python/keyring/keyring-9.3.1.ebuild
parentapp-crypt/monkeysign: Copyright update (diff)
downloadgentoo-ae4baf101dae1c0a3acae6abe898287b4ab7f3e9.tar.gz
gentoo-ae4baf101dae1c0a3acae6abe898287b4ab7f3e9.tar.bz2
gentoo-ae4baf101dae1c0a3acae6abe898287b4ab7f3e9.zip
dev-python/keyring: bup
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/keyring/keyring-9.3.1.ebuild')
-rw-r--r--dev-python/keyring/keyring-9.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-9.3.1.ebuild b/dev-python/keyring/keyring-9.3.1.ebuild
new file mode 100644
index 000000000000..ab7471ad9b9b
--- /dev/null
+++ b/dev-python/keyring/keyring-9.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+python_test() {
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}