summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-03 09:03:46 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-03 09:47:55 +0200
commit286650e3778654007419d7f598729ba9b3ed181b (patch)
treef962c0eb56f0aa1bc5acc14fa3c3b9577629334e /dev-python/keyring
parentdev-haskell/language-bash: bump up to 0.9.0 (diff)
downloadgentoo-286650e3778654007419d7f598729ba9b3ed181b.tar.gz
gentoo-286650e3778654007419d7f598729ba9b3ed181b.tar.bz2
gentoo-286650e3778654007419d7f598729ba9b3ed181b.zip
dev-python/keyring: Bump to 21.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-21.3.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index f115dc8cb68c..8bbc706fe3a5 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1,2 @@
DIST keyring-21.2.1.tar.gz 45535 BLAKE2B b276f5b973c418794561e0d0872761847d4cb81531dde61b75439c73039f49ffc8abf679d622a9381bc6663ffc452c8b6aabc0a4c8e4cfe5ad1c63566b78082d SHA512 35869e37b234d15799907f0efd0193ab3eb9c0799a6da2d843fdad24212b4ab983658b32bd8b09b658174dcb1ddb6d70a85d0af95730d34d8c571f2ecc9a7c8b
+DIST keyring-21.3.0.tar.gz 73120 BLAKE2B 6124e29e4dfa0b4c1f4ad3c1262c282935f860c0aea796a9e66987e64e4737d7f746c9c832b427e49cdadb87e61a33f7bfbd956299400311ff08e59f643cf6ff SHA512 85119a13aeb62456f8b9409990c3f5f6e0c83e9850466ee3b7a3d10e879e3b7fd6d723b2b683a8904b5d20c76fc85471d16aaedbd7ce04d8b88f1d1dd265f0ff
diff --git a/dev-python/keyring/keyring-21.3.0.ebuild b/dev-python/keyring/keyring-21.3.0.ebuild
new file mode 100644
index 000000000000..651413158c99
--- /dev/null
+++ b/dev-python/keyring/keyring-21.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3 python3_{5,6,7})
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/jaraco-packaging \
+ dev-python/rst-linker
+
+python_prepare_all() {
+ sed -i -e 's:--flake8 --black --cov --mypy::' pytest.ini || die
+ # relies on cpython's gc behavior
+ sed -i -e 's:test_traceback_not_referenced:_&:' \
+ tests/test_errors.py || die
+
+ rm tests/backends/test_kwallet.py || die
+
+ distutils-r1_python_prepare_all
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}