summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-26 22:07:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-26 22:07:50 +0100
commit4808916a1460ff841c9d1ab005835da0f0a4966c (patch)
tree3f53fb88bd58c2a865527f05b66d32d3afce448d /dev-python/keyring
parentdev-python/boto3: Bump to 1.16.60 (diff)
downloadgentoo-4808916a1460ff841c9d1ab005835da0f0a4966c.tar.gz
gentoo-4808916a1460ff841c9d1ab005835da0f0a4966c.tar.bz2
gentoo-4808916a1460ff841c9d1ab005835da0f0a4966c.zip
dev-python/keyring: Bump to 22.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-22.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 177ef3c44b60..c4817debb38b 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1,3 +1,4 @@
DIST keyring-21.7.0.tar.gz 46998 BLAKE2B 469d2de254ed88604a40a4e05c001f50986f55296d35b54969cfa8612473cbd5184f36bd6babdfb6631ab908e03f81858434b7e52471a2d366f97293c2c0ed93 SHA512 8fc5e8f0f0cf2a336c6ce900d59fcd31b4ec270d62559a1c2b4c36803428532b463bad0b2ace9af33b6fb0d50de94229449c4ef4042287ecaa8f1fac37c5faf8
DIST keyring-21.8.0.tar.gz 47639 BLAKE2B 3b8b11cd7ea121f9d8544a5775d9f62de23613da0265f0d815687ad311f4a7b6ed431142682df3059fbe43a342c6151871782a850c416a5b50c1df14a64d609a SHA512 4acadf421946644466b5c43481eddd111170185ba3993f4fec38cad0129259bd17aebad4dc2e2d2e88e84aa814e62d37b39efe7385ccd569e40a5291d5f4ae40
DIST keyring-22.0.0.tar.gz 47693 BLAKE2B 88a151327778e5e039c43caa68e53705d985d6ef2b7b668df1d941160b843f47a0e2f6f79c9afc39bc66a36373c0374333296a3cb98f1c65c620a8fad3f43fec SHA512 5e9e27cf9b09f042747909b442864a1ea0669b36f69592538b487978a582e16e58056d6bd68b35566143000ed3f5c7733e3ef471c66935a811e09fc4b7f56f6f
+DIST keyring-22.0.1.tar.gz 47782 BLAKE2B ec9f5c0418b2c279f111cbcb8ccc1fc05f64e859e2e675041289a639c7e2d4681e562c9c023e46f1eacb99f88114af97545ad36f71037db0b77e83d927785ce0 SHA512 2e264570d2e905ce4862d71fe4b02fcf0631218a693292c13159fdbad0032e91d81910f84d787e948057e2f428fcf8677ebdd83af4da54c3359347f642db0441
diff --git a/dev-python/keyring/keyring-22.0.1.ebuild b/dev-python/keyring/keyring-22.0.1.ebuild
new file mode 100644
index 000000000000..d62127ef81b5
--- /dev/null
+++ b/dev-python/keyring/keyring-22.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3 python3_7)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/jaraco-packaging \
+ dev-python/rst-linker
+
+python_prepare_all() {
+ rm tests/backends/test_kwallet.py || die
+
+ distutils-r1_python_prepare_all
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}