summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-08-30 15:43:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-08-30 16:34:37 -0500
commit79376705c45769163a4cbd99abc6db95c45ac37f (patch)
treed206e4587a8c323c6d5d77712a347fe4f8b75ac6 /dev-python/keystoneauth/keystoneauth-3.10.0.ebuild
parentdev-python/os-service-types: 1.3.0 bump for rocky (diff)
downloadgentoo-79376705c45769163a4cbd99abc6db95c45ac37f.tar.gz
gentoo-79376705c45769163a4cbd99abc6db95c45ac37f.tar.bz2
gentoo-79376705c45769163a4cbd99abc6db95c45ac37f.zip
dev-python/keystoneauth: 3.10.0 bump for rocky
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/keystoneauth/keystoneauth-3.10.0.ebuild')
-rw-r--r--dev-python/keystoneauth/keystoneauth-3.10.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/keystoneauth-3.10.0.ebuild b/dev-python/keystoneauth/keystoneauth-3.10.0.ebuild
new file mode 100644
index 000000000000..a1da7672be0f
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-3.10.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"