summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:06:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-16 16:21:26 -0500
commit5f1ae3504d4c2605f093b9108afb3ca307e63f64 (patch)
tree5f8b91daf363910877093b2a1b526b317b2adb66 /dev-python/keystoneauth/keystoneauth-4.0.0.ebuild
parentsys-cluster/nova: 21.0.0 ussuri bump (diff)
downloadgentoo-5f1ae3504d4c2605f093b9108afb3ca307e63f64.tar.gz
gentoo-5f1ae3504d4c2605f093b9108afb3ca307e63f64.tar.bz2
gentoo-5f1ae3504d4c2605f093b9108afb3ca307e63f64.zip
dev-python/keystoneauth: 4.0.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth/keystoneauth-4.0.0.ebuild')
-rw-r--r--dev-python/keystoneauth/keystoneauth-4.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/keystoneauth-4.0.0.ebuild b/dev-python/keystoneauth/keystoneauth-4.0.0.ebuild
new file mode 100644
index 000000000000..84a1f46cc6cb
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-4.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"