summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 15:39:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 16:01:18 +0200
commit1c233ced96b7cafb033e33bd187f026fd9e5571e (patch)
tree5b3d8a310600cf532186e88223aff4bba60ddfee /dev-python/lark
parentgames-kids/gmult: fix build with meson-0.62.1 (diff)
downloadgentoo-1c233ced96b7cafb033e33bd187f026fd9e5571e.tar.gz
gentoo-1c233ced96b7cafb033e33bd187f026fd9e5571e.tar.bz2
gentoo-1c233ced96b7cafb033e33bd187f026fd9e5571e.zip
dev-python/lark: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lark')
-rw-r--r--dev-python/lark/lark-1.1.2.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-python/lark/lark-1.1.2.ebuild b/dev-python/lark/lark-1.1.2.ebuild
index 8c13517ad359..70ffb4ad1324 100644
--- a/dev-python/lark/lark-1.1.2.ebuild
+++ b/dev-python/lark/lark-1.1.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -18,8 +18,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/lark/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
BDEPEND="
test? (
@@ -28,6 +26,19 @@ BDEPEND="
)
"
+distutils_enable_tests pytest
+
python_test() {
- "${EPYTHON}" -m tests -v || die "Tests fail with ${EPYTHON}"
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # require dev-python/js2py which is a really bad quality package
+ tests/test_nearley/test_nearley.py
+ )
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # https://github.com/lark-parser/lark/issues/1146
+ tests/test_trees.py::TestTrees::test_smart_decorator
+ )
+
+ epytest
}