summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Pettersson <william@ewpettersson.se>2021-01-22 11:42:05 +0000
committerSam James <sam@gentoo.org>2021-01-23 03:37:34 +0000
commit7c0d15ab0030e5405a295d92ebfaafe66e1c5bdd (patch)
tree3253fa113dad0d5c97928e2afcf795659f40385f /dev-python/latexcodec/latexcodec-2.0.1.ebuild
parentapp-crypt/openpgp-keys-python: Stabilize 20210121 arm, #766189 (diff)
downloadgentoo-7c0d15ab0030e5405a295d92ebfaafe66e1c5bdd.tar.gz
gentoo-7c0d15ab0030e5405a295d92ebfaafe66e1c5bdd.tar.bz2
gentoo-7c0d15ab0030e5405a295d92ebfaafe66e1c5bdd.zip
dev-python/latexcodec: Version bump to 2.0.1
Some new translations added Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: William Pettersson <william@ewpettersson.se> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/latexcodec/latexcodec-2.0.1.ebuild')
-rw-r--r--dev-python/latexcodec/latexcodec-2.0.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/latexcodec/latexcodec-2.0.1.ebuild b/dev-python/latexcodec/latexcodec-2.0.1.ebuild
new file mode 100644
index 000000000000..d0b505b9f685
--- /dev/null
+++ b/dev-python/latexcodec/latexcodec-2.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lexer and codec to work with LaTeX code in Python"
+HOMEPAGE="https://github.com/mcmtroffaes/latexcodec/ https://pypi.org/project/latexcodec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest