summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-02-07 11:06:29 +0100
committerHanno Böck <hanno@gentoo.org>2020-02-07 11:06:29 +0100
commit37f7b2095ade715d6faa59790bb52ecaa94326b9 (patch)
tree5f75d8a4e4293e566fc8893211828f68fd03b49f /dev-python/lazr-config/lazr-config-2.2.2.ebuild
parentdev-python/lazr-delegates: Add python 3.7/3.8, remove python 2. (diff)
downloadgentoo-37f7b2095ade715d6faa59790bb52ecaa94326b9.tar.gz
gentoo-37f7b2095ade715d6faa59790bb52ecaa94326b9.tar.bz2
gentoo-37f7b2095ade715d6faa59790bb52ecaa94326b9.zip
dev-python/lazr-config: Bump, add python 3.7/3.8, remove python 2.
Closes: https://bugs.gentoo.org/705336 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.87, Repoman-2.3.20
Diffstat (limited to 'dev-python/lazr-config/lazr-config-2.2.2.ebuild')
-rw-r--r--dev-python/lazr-config/lazr-config-2.2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/lazr-config/lazr-config-2.2.2.ebuild b/dev-python/lazr-config/lazr-config-2.2.2.ebuild
new file mode 100644
index 000000000000..1b3afe149d60
--- /dev/null
+++ b/dev-python/lazr-config/lazr-config-2.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Create configuration schemas, and process and validate configurations."
+HOMEPAGE="https://code.launchpad.net/lazr.config"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/lazr-delegates[${PYTHON_USEDEP}]"