summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-26 08:22:58 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-26 09:51:42 +0100
commit5ebf4943334723f9b7141a914becfbb32df3e0a2 (patch)
tree279e600a8789d82e344b5d7e7123e09d54ea4c10 /dev-python/ldap3/ldap3-1.0.3.ebuild
parentsys-cluster/pacemaker: version bump fix #572062 (diff)
downloadgentoo-5ebf4943334723f9b7141a914becfbb32df3e0a2.tar.gz
gentoo-5ebf4943334723f9b7141a914becfbb32df3e0a2.tar.bz2
gentoo-5ebf4943334723f9b7141a914becfbb32df3e0a2.zip
dev-python/ldap3: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ldap3/ldap3-1.0.3.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-1.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-1.0.3.ebuild b/dev-python/ldap3/ldap3-1.0.3.ebuild
new file mode 100644
index 000000000000..ca63212c9d27
--- /dev/null
+++ b/dev-python/ldap3/ldap3-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v -s test || die
+}