summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 23:37:01 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:51 -0500
commita62564f4cdb3820ebae51fa343725bef9743016e (patch)
tree6ac69ce7fd7a3f1442d9488bd0e56e36b6e13256 /dev-python/ldappool/ldappool-2.4.1.ebuild
parentdev-python/python-ldap: 3.1.0-r1 adding py37 (diff)
downloadgentoo-a62564f4cdb3820ebae51fa343725bef9743016e.tar.gz
gentoo-a62564f4cdb3820ebae51fa343725bef9743016e.tar.bz2
gentoo-a62564f4cdb3820ebae51fa343725bef9743016e.zip
dev-python/ldappool: 2.4.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/ldappool/ldappool-2.4.1.ebuild')
-rw-r--r--dev-python/ldappool/ldappool-2.4.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ldappool/ldappool-2.4.1.ebuild b/dev-python/ldappool/ldappool-2.4.1.ebuild
new file mode 100644
index 000000000000..8368cfa3327f
--- /dev/null
+++ b/dev-python/ldappool/ldappool-2.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/python-ldap-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+"