summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-19 14:25:34 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-19 14:25:34 +0200
commit6be62b70d00369735e314439d6786d0a522976dc (patch)
tree725942dc3f01069bfdc03840e33d3c43b28d6aff /dev-python/libnacl/libnacl-1.6.0.ebuild
parentapp-admin/consul: Version bump to 1.0.0 (diff)
downloadgentoo-6be62b70d00369735e314439d6786d0a522976dc.tar.gz
gentoo-6be62b70d00369735e314439d6786d0a522976dc.tar.bz2
gentoo-6be62b70d00369735e314439d6786d0a522976dc.zip
dev-python/libnacl: Version bump to 1.6.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-python/libnacl/libnacl-1.6.0.ebuild')
-rw-r--r--dev-python/libnacl/libnacl-1.6.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/libnacl/libnacl-1.6.0.ebuild b/dev-python/libnacl/libnacl-1.6.0.ebuild
new file mode 100644
index 000000000000..b263cddf7919
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="https://github.com/saltstack/libnacl/archive/v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/libsodium"
+
+python_test() {
+ ${EPYTHON} tests/runtests.py || die
+}