summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-03-10 22:09:59 -0600
committerMatthias Maier <tamiko@gentoo.org>2021-03-10 22:26:03 -0600
commit3798efc49f1d39f42a26ba84b9910edabd64f696 (patch)
tree13e6fb06588b5848b0b97510c3dfe98b8a7431f2 /dev-python/libvirt-python
parentapp-emulation/libvirt: version bump to 7.1.0 (diff)
downloadgentoo-3798efc49f1d39f42a26ba84b9910edabd64f696.tar.gz
gentoo-3798efc49f1d39f42a26ba84b9910edabd64f696.tar.bz2
gentoo-3798efc49f1d39f42a26ba84b9910edabd64f696.zip
dev-python/libvirt-python: version bump to 7.1.0
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-7.1.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 02025edee573..fd606c9761cd 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-python-6.8.0.tar.gz 210034 BLAKE2B 667c2713bf9c0936f444c5b621f5af4e5273deda31496bc01c8834286a0ec0eb1c056006549cc5d129ef597264f8582acee62db3a2fd375daa4ebbceacb8fcc1 SHA512 6d2f82fafd414047cff16f0ad655fefd69c8c0da04be07d27da44e3ab17dd03e4e4ff102be1c30948c361268f57ea312978f9198fd128bfb54a3c1a07150e6af
DIST libvirt-python-7.0.0.tar.gz 214945 BLAKE2B 9ab616fa6336a284dbb1dcebf0be6a06d9ca0c41e83ca403cb335c61ff217e1e9f0343fc915e20e16f3e59adc5c7b1c51e493143c45cd50f48f627ebe2e9c211 SHA512 c56bc53da06a81d330389f684df204d0ae8edb28127eccd81ac551342a0965341d20832f6e2b044e02e9217320349f6f5cb36098c5cc46508a4026fb1e59c4ac
+DIST libvirt-python-7.1.0.tar.gz 215468 BLAKE2B 5734f686760d118bc326c68d93714db31b65d0d2f8495c8fb7788aa59658680cc07b8c522e5854bafc6a75989cee4b7c817ec0f54ae5ebcb76ed74418fa1c0f0 SHA512 9c4adf0107b2b6d8ac3f84f4a201733b851b5c518e498b4bb8fe3531ec8923b2a96e5593ee0fe309b9501884a83e77a6a0347a6714293febf907c9a4dc742cd4
diff --git a/dev-python/libvirt-python/libvirt-python-7.1.0.ebuild b/dev-python/libvirt-python/libvirt-python-7.1.0.ebuild
new file mode 100644
index 000000000000..cb778ad7f1cb
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-7.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}