summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-21 21:39:55 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-21 21:40:45 +0200
commit42ac89c1bc3e0c83af451c5a3fcc4779935530cf (patch)
tree245f8066b4932f1bc667dc38f314a7e0379fd05e /dev-python/libvirt-python
parentnet-analyzer/nessus-agent-bin: switch to ES8 binaries (diff)
downloadgentoo-42ac89c1bc3e0c83af451c5a3fcc4779935530cf.tar.gz
gentoo-42ac89c1bc3e0c83af451c5a3fcc4779935530cf.tar.bz2
gentoo-42ac89c1bc3e0c83af451c5a3fcc4779935530cf.zip
dev-python/libvirt-python: bump to 6.5.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-6.5.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 395598f57ab8..d05534d8dbfe 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1 +1,2 @@
DIST libvirt-python-6.2.0.tar.gz 196971 BLAKE2B e11c82bd98c62072c14992c485339337bcc3639bbd56154185834c145f76984ced9f09f7f05c302609ce6629a8d13db77debd6f3d85e8fdb00c818bbe51cc552 SHA512 91f6940f60670221c914ee7ffc8d89a74222bcacbbf1afd5f679479f1e1bcec563f297a8e8359d6f51a1eee29162e39e2a276f5277fcec551d50f112e304a947
+DIST libvirt-python-6.5.0.tar.gz 198753 BLAKE2B 90951af538c664f5da20cfced6b81dc2b06d36e723b3c41a0b2763bf0d73d3036d7e84a2db57f20fa2bd1ede8fb01c45dad9e5097a9f6008579dae319f825898 SHA512 a69c75b615f674bbb89fdb3e5cfc3dddfde68adffd0599e9d03f1552bb765823dc003859fe713ac0a324835c61f909bd43518571ddde8f99c37bee2416f094eb
diff --git a/dev-python/libvirt-python/libvirt-python-6.5.0.ebuild b/dev-python/libvirt-python/libvirt-python-6.5.0.ebuild
new file mode 100644
index 000000000000..d6867cec6ffc
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-6.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="virtual/pkgconfig"
+BDEPEND="test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}