summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-12-25 14:02:25 -0600
committerMatthias Maier <tamiko@gentoo.org>2020-12-25 14:02:25 -0600
commit5db717a67be2fa3fe5722371d83aff37393045b2 (patch)
treef7d6a2883ee052c42703c24e42b3236ebafcd505 /dev-python/libvirt-python
parentapp-emulation/virt-manager: update dependencies (diff)
downloadgentoo-5db717a67be2fa3fe5722371d83aff37393045b2.tar.gz
gentoo-5db717a67be2fa3fe5722371d83aff37393045b2.tar.bz2
gentoo-5db717a67be2fa3fe5722371d83aff37393045b2.zip
dev-python/libvirt-python: drop vulnerable
Bug: https://bugs.gentoo.org/746119 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest3
-rw-r--r--dev-python/libvirt-python/libvirt-python-6.7.0.ebuild46
2 files changed, 1 insertions, 48 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 1e4985e5ee0b..fff7b02939ad 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,4 +1,3 @@
-DIST libvirt-python-6.7.0.tar.gz 208597 BLAKE2B 335bd89133b688586a55193635b4b75dabe6dd4a741a450e49067ac8a9b9d9da54787b50c23bc6d5322a7fecbe513422f02450e09d541cb112ccfd499ce18101 SHA512 7d5a7f87abc01285c2030c9408838d4e1496d0d0316b9ab775749e49719fa66c20114aad2bd281d6783e2cb4d47ceac5ac60ac584e881288d0b0d9cc76d5b2cb
+DIST libvirt-python-6.10.0.tar.gz 212567 BLAKE2B 0ba583646c16c8e298a4cde789dca9c0f4920a3ac7e241134e251e5d0fc426a37c297870571acc673de2ce14c3de5bb7069316805581ce33cc044090930dd599 SHA512 bc9d65fa82cf021c0929c8f2760a31de606d52c860d15d1961438fd763131f05fa3f4e12f0030b45ad12c3ae40d84b21167091ae810376487b7aae11c2e3ab2b
DIST libvirt-python-6.8.0.tar.gz 210034 BLAKE2B 667c2713bf9c0936f444c5b621f5af4e5273deda31496bc01c8834286a0ec0eb1c056006549cc5d129ef597264f8582acee62db3a2fd375daa4ebbceacb8fcc1 SHA512 6d2f82fafd414047cff16f0ad655fefd69c8c0da04be07d27da44e3ab17dd03e4e4ff102be1c30948c361268f57ea312978f9198fd128bfb54a3c1a07150e6af
DIST libvirt-python-6.9.0.tar.gz 210366 BLAKE2B 384d8ce4d6c91f7185484e3ad35572a3245712c59f416d0f117ce7936d1e6234458c3454a8d773ee287de4d529eae7229e3dd67111df7955369cd36b028be1cc SHA512 d15a80de5418586f769101525464efc88154c9038f59c805030a60b4b711f11f15531f4e1fd01575e1646397342fefa38fca9371e8146157b61f607b3c286fe1
-DIST libvirt-python-6.10.0.tar.gz 212567 BLAKE2B 0ba583646c16c8e298a4cde789dca9c0f4920a3ac7e241134e251e5d0fc426a37c297870571acc673de2ce14c3de5bb7069316805581ce33cc044090930dd599 SHA512 bc9d65fa82cf021c0929c8f2760a31de606d52c860d15d1961438fd763131f05fa3f4e12f0030b45ad12c3ae40d84b21167091ae810376487b7aae11c2e3ab2b
diff --git a/dev-python/libvirt-python/libvirt-python-6.7.0.ebuild b/dev-python/libvirt-python/libvirt-python-6.7.0.ebuild
deleted file mode 100644
index c8cc20f3c018..000000000000
--- a/dev-python/libvirt-python/libvirt-python-6.7.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-DISTUTILS_USE_SETUPTOOLS=no
-
-MY_P="${P/_rc/-rc}"
-
-inherit distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
- RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
- SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~ppc64 x86"
- RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="https://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="virtual/pkgconfig"
-BDEPEND="test? (
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_tests setup.py
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}