summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-08-11 22:49:19 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-08-11 22:49:19 -0500
commit72373dd80dbc9cd31030b63f88e755d3f08b6c80 (patch)
treecc337e7d49d184d049ceed0c130a7e4c3571a000 /dev-python/libvirt-python
parentapp-emulation/libvirt: version bump to 5.6.0 (diff)
downloadgentoo-72373dd80dbc9cd31030b63f88e755d3f08b6c80.tar.gz
gentoo-72373dd80dbc9cd31030b63f88e755d3f08b6c80.tar.bz2
gentoo-72373dd80dbc9cd31030b63f88e755d3f08b6c80.zip
dev-python/libvirt-python: version bump to 5.6.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-5.6.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 41a3202009f2..0fed2c628a23 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-python-5.2.0.tar.gz 193270 BLAKE2B fecd1a07091746779a91e0cfeb9c3068048ee7e51d2f79064b4ee529a19b78d04ba53a5abab68182a1fa9c4a82f459fa9e971c33fcd10b42fe7011be17f7c6e2 SHA512 afee2dcaf08d530e6298fdf2db674af217b9e4115941258b5815aba00087d96db6eb421c9854d7dca0f9dfe24069df72aadd969c924545e72be216f01bc173cc
DIST libvirt-python-5.5.0.tar.gz 200364 BLAKE2B 198c9858573c383ab818deae6bd42c6ad7efd58b9a661a80f06f4f0fc0d72e9da98546b07443397609d4c9454ece4e02759b53016f078bdae84580474e2bb49d SHA512 3098c5a0315488aa515a9b00e69add8de3dc372d2f82a8b1cbc6d01287a133855095f7c34510ad900adbd1c56e6a53bdfe3d251c48411acd243c2300d659332b
+DIST libvirt-python-5.6.0.tar.gz 201352 BLAKE2B 16f88b9c15214af0ec97ee39912139d6ab07473a9f65a735303f5241d10d75e46db68378b33c9c139f6a9e43f7143a4c30fdbe187e50e004cfb5205dda03d0a3 SHA512 a6bf7c661127ae0ed5962ed7bc9cefe09907e82969525ee0ea8f8f70b5fee8f200b6ba9d35aefcb7b132f59e34162ba40e75e93aff297808bc1dd23f548da428
diff --git a/dev-python/libvirt-python/libvirt-python-5.6.0.ebuild b/dev-python/libvirt-python/libvirt-python-5.6.0.ebuild
new file mode 100644
index 000000000000..a020f3273876
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-5.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}