summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-05-27 16:31:18 -0700
committerMatthias Maier <tamiko@gentoo.org>2018-05-27 19:21:25 -0500
commitc9b9b1dfcfa996cab97945e507c3fe6f18a1bb93 (patch)
tree973f1c34cbe5295d265bbffacaf0ed19633a8dde /dev-python/libvirt-python
parentdev-python/libvirt-python: add python-3.6 support (diff)
downloadgentoo-c9b9b1dfcfa996cab97945e507c3fe6f18a1bb93.tar.gz
gentoo-c9b9b1dfcfa996cab97945e507c3fe6f18a1bb93.tar.bz2
gentoo-c9b9b1dfcfa996cab97945e507c3fe6f18a1bb93.zip
dev-python/libvirt-python: cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.2.0.ebuild46
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.3.0.ebuild46
2 files changed, 0 insertions, 92 deletions
diff --git a/dev-python/libvirt-python/libvirt-python-4.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.2.0.ebuild
deleted file mode 100644
index 172f3dc38862..000000000000
--- a/dev-python/libvirt-python/libvirt-python-4.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-MY_P="${P/_rc/-rc}"
-
-inherit distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
- SRC_URI=""
- KEYWORDS=""
- RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
- SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="https://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="examples test"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/libvirt-python/libvirt-python-4.3.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.3.0.ebuild
deleted file mode 100644
index 172f3dc38862..000000000000
--- a/dev-python/libvirt-python/libvirt-python-4.3.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-MY_P="${P/_rc/-rc}"
-
-inherit distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
- SRC_URI=""
- KEYWORDS=""
- RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
- SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="https://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="examples test"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}