summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-01-15 14:33:07 +0000
committerSam James <sam@gentoo.org>2021-01-17 04:34:29 +0000
commitfb0901e3013fdf5b47cc347c9c9138a6761cee1f (patch)
treeee11f2ced10f386cacd6709e3189105d0a2b500a /dev-python/libvirt-python
parentsys-libs/nss-usrfiles: EAPI 7 (diff)
downloadgentoo-fb0901e3013fdf5b47cc347c9c9138a6761cee1f.tar.gz
gentoo-fb0901e3013fdf5b47cc347c9c9138a6761cee1f.tar.bz2
gentoo-fb0901e3013fdf5b47cc347c9c9138a6761cee1f.zip
dev-python/libvirt-python: Version updated to 7.0.0.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-7.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index fff7b02939ad..2af3329852d2 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,3 +1,4 @@
DIST libvirt-python-6.10.0.tar.gz 212567 BLAKE2B 0ba583646c16c8e298a4cde789dca9c0f4920a3ac7e241134e251e5d0fc426a37c297870571acc673de2ce14c3de5bb7069316805581ce33cc044090930dd599 SHA512 bc9d65fa82cf021c0929c8f2760a31de606d52c860d15d1961438fd763131f05fa3f4e12f0030b45ad12c3ae40d84b21167091ae810376487b7aae11c2e3ab2b
DIST libvirt-python-6.8.0.tar.gz 210034 BLAKE2B 667c2713bf9c0936f444c5b621f5af4e5273deda31496bc01c8834286a0ec0eb1c056006549cc5d129ef597264f8582acee62db3a2fd375daa4ebbceacb8fcc1 SHA512 6d2f82fafd414047cff16f0ad655fefd69c8c0da04be07d27da44e3ab17dd03e4e4ff102be1c30948c361268f57ea312978f9198fd128bfb54a3c1a07150e6af
DIST libvirt-python-6.9.0.tar.gz 210366 BLAKE2B 384d8ce4d6c91f7185484e3ad35572a3245712c59f416d0f117ce7936d1e6234458c3454a8d773ee287de4d529eae7229e3dd67111df7955369cd36b028be1cc SHA512 d15a80de5418586f769101525464efc88154c9038f59c805030a60b4b711f11f15531f4e1fd01575e1646397342fefa38fca9371e8146157b61f607b3c286fe1
+DIST libvirt-python-7.0.0.tar.gz 214945 BLAKE2B 9ab616fa6336a284dbb1dcebf0be6a06d9ca0c41e83ca403cb335c61ff217e1e9f0343fc915e20e16f3e59adc5c7b1c51e493143c45cd50f48f627ebe2e9c211 SHA512 c56bc53da06a81d330389f684df204d0ae8edb28127eccd81ac551342a0965341d20832f6e2b044e02e9217320349f6f5cb36098c5cc46508a4026fb1e59c4ac
diff --git a/dev-python/libvirt-python/libvirt-python-7.0.0.ebuild b/dev-python/libvirt-python/libvirt-python-7.0.0.ebuild
new file mode 100644
index 000000000000..234224f5717f
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-7.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="virtual/pkgconfig"
+BDEPEND="test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}