summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 09:14:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:05:32 +0200
commit4c89740ffc1799aefcec51e49889e0b74f0474c5 (patch)
treed8edce1ac639e79a2029d982b3d1b706dfe01dc8 /dev-python/license-expression
parentdev-python/sentry-sdk: Bump to 1.5.12 (diff)
downloadgentoo-4c89740ffc1799aefcec51e49889e0b74f0474c5.tar.gz
gentoo-4c89740ffc1799aefcec51e49889e0b74f0474c5.tar.bz2
gentoo-4c89740ffc1799aefcec51e49889e0b74f0474c5.zip
dev-python/license-expression: Bump to 30.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/license-expression')
-rw-r--r--dev-python/license-expression/Manifest1
-rw-r--r--dev-python/license-expression/license-expression-30.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/license-expression/Manifest b/dev-python/license-expression/Manifest
index 24ba1af8ede5..092af4f2c365 100644
--- a/dev-python/license-expression/Manifest
+++ b/dev-python/license-expression/Manifest
@@ -1 +1,2 @@
DIST license-expression-21.6.14.gh.tar.gz 107788 BLAKE2B 18e123be256df2de289b00f292782fd5010333f692ba56caea448bf9a5102d2a11868a3c85787b5cd8129a9d3f9728e0776fa7658d00efe79c124a40f2263683 SHA512 12c4333a53f30c73f123434c9e50ee50163a3bad5831e756cc1350c14daa062b939e8382f4bcf2fef11020f8bec5185f71302f3c68ae88cd59b8da9a5f2964f4
+DIST license-expression-30.0.0.gh.tar.gz 153630 BLAKE2B 4231bf14e69705fbf40cc4af5f17a1070c780d595db5ab0098b318eeb7289740b86319c683e61aaf844a1cc5b8598d832f14e4eeac354aff37f7b82e5437df1d SHA512 ce6e3a48c1e035e98c3831180bdafb1d70afe94b1d0148c47941129a8223b8b39e11af9407b255ed7a3d1247873c18848f8236c0a805e9b2333c6d59506aad12
diff --git a/dev-python/license-expression/license-expression-30.0.0.ebuild b/dev-python/license-expression/license-expression-30.0.0.ebuild
new file mode 100644
index 000000000000..5d75eaf15fe9
--- /dev/null
+++ b/dev-python/license-expression/license-expression-30.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Parse, compare, simplify and normalize license expressions"
+HOMEPAGE="
+ https://pypi.org/project/license-expression/
+ https://github.com/nexB/license-expression/
+"
+SRC_URI="
+ https://github.com/nexB/license-expression/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/boolean-py-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}