summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-22 20:25:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-22 20:28:50 +0200
commite856e025b9da9a2596143aea645111d6516d4ab8 (patch)
treef1ff146705d23b2b2ea770ffb823a50467446e8d /dev-python/line-profiler
parentdev-python/line_profiler: Prepare for rename (diff)
downloadgentoo-e856e025b9da9a2596143aea645111d6516d4ab8.tar.gz
gentoo-e856e025b9da9a2596143aea645111d6516d4ab8.tar.bz2
gentoo-e856e025b9da9a2596143aea645111d6516d4ab8.zip
Rename dev-python/{line_profiler → line-profiler}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/line-profiler')
-rw-r--r--dev-python/line-profiler/Manifest1
-rw-r--r--dev-python/line-profiler/line-profiler-4.1.0.ebuild47
-rw-r--r--dev-python/line-profiler/metadata.xml21
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/line-profiler/Manifest b/dev-python/line-profiler/Manifest
new file mode 100644
index 000000000000..58cb858bdbd3
--- /dev/null
+++ b/dev-python/line-profiler/Manifest
@@ -0,0 +1 @@
+DIST line_profiler-4.1.0.gh.tar.gz 99250 BLAKE2B aa875dfb8cdbaaa701a03d10fd904504825d58e551dddabddbe0abca777a584bae5c37f4b3ab80d10dc869138106d70c3ff243a7d28e570983427520dd4ee569 SHA512 08e0395b80f8c111725227abea7e8b2d6864da840a0a6f4de5eb71a2df2ae78871c930897b49d75a184973c1ce21d61106817bd0b8d4556462f0505bbbc21fe1
diff --git a/dev-python/line-profiler/line-profiler-4.1.0.ebuild b/dev-python/line-profiler/line-profiler-4.1.0.ebuild
new file mode 100644
index 000000000000..5ffe92f3463f
--- /dev/null
+++ b/dev-python/line-profiler/line-profiler-4.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=line_profiler-${PV}
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# <cython-3: https://bugs.gentoo.org/911735
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export LINE_PROFILER_BUILD_METHOD=cython
+
+python_test() {
+ cd tests || die
+ epytest
+}
diff --git a/dev-python/line-profiler/metadata.xml b/dev-python/line-profiler/metadata.xml
new file mode 100644
index 000000000000..1b582c391cb4
--- /dev/null
+++ b/dev-python/line-profiler/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ line_profiler is a module for doing line-by-line profiling of
+ functions. kernprof is a convenient script for running either
+ line_profiler or the Python standard library's cProfile or profile
+ modules, depending on what is available.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">line-profiler</remote-id>
+ <remote-id type="github">pyutils/line_profiler</remote-id>
+ </upstream>
+</pkgmetadata>