summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-15 13:57:51 +0100
committerBenda Xu <heroxbd@gentoo.org>2020-02-09 20:43:50 +0800
commit85112c6c3024d0284417621fca05373c5d389a01 (patch)
tree5b8312739ab1b6951b3d54b50cc35e96965a4e96 /dev-python/line_profiler/line_profiler-3.0.2.ebuild
parentdev-python/xdoctest: A rewrite of Python's builtin doctest module (diff)
downloadgentoo-85112c6c3024d0284417621fca05373c5d389a01.tar.gz
gentoo-85112c6c3024d0284417621fca05373c5d389a01.tar.bz2
gentoo-85112c6c3024d0284417621fca05373c5d389a01.zip
dev-python/line_profiler: Version bump 3.0.2
Add py3_7 Put setuptools in rdepend Closes: https://github.com/gentoo/gentoo/pull/14344 Closes: https://bugs.gentoo.org/705872 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/line_profiler/line_profiler-3.0.2.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-3.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/line_profiler/line_profiler-3.0.2.ebuild b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
new file mode 100644
index 000000000000..e7db155b3e30
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/pyutils/line_profiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest