summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:14:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:36 +0200
commit82e0d2d015be20af3fccace2145452fe0c131255 (patch)
tree874b88dc5b69a09f472a752dafe9d868021f738b /dev-python/linecache2/linecache2-1.0.0-r1.ebuild
parentdev-python/traceback2: Remove python2 (diff)
downloadgentoo-82e0d2d015be20af3fccace2145452fe0c131255.tar.gz
gentoo-82e0d2d015be20af3fccace2145452fe0c131255.tar.bz2
gentoo-82e0d2d015be20af3fccace2145452fe0c131255.zip
dev-python/linecache2: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/linecache2/linecache2-1.0.0-r1.ebuild')
-rw-r--r--dev-python/linecache2/linecache2-1.0.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/linecache2/linecache2-1.0.0-r1.ebuild b/dev-python/linecache2/linecache2-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..95453da06aa1
--- /dev/null
+++ b/dev-python/linecache2/linecache2-1.0.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Backports of the linecache module"
+HOMEPAGE="https://github.com/testing-cabal/linecache2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"
+}