summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-05 04:38:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-05 04:47:36 +0100
commit823dcb78f159bcbab6102ae1fe53d34f2be66785 (patch)
tree76464cb783ae12e18b0b468d852bb29d4bf089a2 /dev-python/linkify-it-py/linkify-it-py-2.0.3.ebuild
parentdev-python/astroid: Bump to 3.0.3 (diff)
downloadgentoo-823dcb78f159bcbab6102ae1fe53d34f2be66785.tar.gz
gentoo-823dcb78f159bcbab6102ae1fe53d34f2be66785.tar.bz2
gentoo-823dcb78f159bcbab6102ae1fe53d34f2be66785.zip
dev-python/linkify-it-py: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/linkify-it-py/linkify-it-py-2.0.3.ebuild')
-rw-r--r--dev-python/linkify-it-py/linkify-it-py-2.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/linkify-it-py/linkify-it-py-2.0.3.ebuild b/dev-python/linkify-it-py/linkify-it-py-2.0.3.ebuild
new file mode 100644
index 000000000000..f62767cacaf0
--- /dev/null
+++ b/dev-python/linkify-it-py/linkify-it-py-2.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Links recognition library with full unicode support"
+HOMEPAGE="
+ https://github.com/tsutsu3/linkify-it-py/
+ https://pypi.org/project/linkify-it-py/
+"
+# no tests in sdist, as of 2.0.1
+SRC_URI="
+ https://github.com/tsutsu3/linkify-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/uc-micro-py[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest