summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 18:37:40 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-03 12:46:12 +0100
commit48e800a34207510703a668c562ad7f061a208ed5 (patch)
treeb646fb4a6de5ba76b4d468f01a3a26b97cf04d66 /dev-python/lit/lit-10.0.0.9999.ebuild
parentdev-ml/llvm-ocaml: Port 9+ to llvm.org.eclass (diff)
downloadgentoo-48e800a34207510703a668c562ad7f061a208ed5.tar.gz
gentoo-48e800a34207510703a668c562ad7f061a208ed5.tar.bz2
gentoo-48e800a34207510703a668c562ad7f061a208ed5.zip
dev-python/lit: Port 9+ to llvm.org.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit/lit-10.0.0.9999.ebuild')
-rw-r--r--dev-python/lit/lit-10.0.0.9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/lit/lit-10.0.0.9999.ebuild b/dev-python/lit/lit-10.0.0.9999.ebuild
index 05acb219e329..e051ca51410e 100644
--- a/dev-python/lit/lit-10.0.0.9999.ebuild
+++ b/dev-python/lit/lit-10.0.0.9999.ebuild
@@ -4,13 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-inherit distutils-r1 git-r3 multiprocessing
+inherit distutils-r1 llvm.org multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/llvm/utils/lit
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -27,11 +26,6 @@ BDEPEND="
# TODO: move the manpage generation here (from sys-devel/llvm)
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' llvm/utils/lit
-}
-
python_test() {
local -x LIT_PRESERVES_TMP=1
./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \