summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-20 10:52:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-20 14:49:51 +0200
commit3d7fe26b9c7d4bf5ee15491a96db684523e44b68 (patch)
tree792ab37cb3f71a2c296e56970bb5236c3052bd50 /dev-python/lit/lit-8.0.1.ebuild
parentsys-devel/llvm: Bump to 8.0.1 (diff)
downloadgentoo-3d7fe26b9c7d4bf5ee15491a96db684523e44b68.tar.gz
gentoo-3d7fe26b9c7d4bf5ee15491a96db684523e44b68.tar.bz2
gentoo-3d7fe26b9c7d4bf5ee15491a96db684523e44b68.zip
dev-python/lit: Bump to 8.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit/lit-8.0.1.ebuild')
-rw-r--r--dev-python/lit/lit-8.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lit/lit-8.0.1.ebuild b/dev-python/lit/lit-8.0.1.ebuild
new file mode 100644
index 000000000000..a5c86ceac3bc
--- /dev/null
+++ b/dev-python/lit/lit-8.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1 multiprocessing
+
+MY_P=llvm-${PV/_/}.src
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://github.com/llvm/llvm-project/releases/download/llvmorg-${PV}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${MY_P}/utils/lit
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/lit" || die
+}
+
+python_test() {
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
+}