summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 22:57:28 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:52 +0100
commit25bd6378d4a39b05c085c91de2abbdfbb721b42e (patch)
tree807ef542efb03c69bf7e1e3fadca7f9b3adef505 /dev-python/lit
parentdev-java/icedtea-bin: Version bump to 3.7.0 with security fixes (diff)
downloadgentoo-25bd6378d4a39b05c085c91de2abbdfbb721b42e.tar.gz
gentoo-25bd6378d4a39b05c085c91de2abbdfbb721b42e.tar.bz2
gentoo-25bd6378d4a39b05c085c91de2abbdfbb721b42e.zip
dev-python/lit: Control lit job count
Closes: https://bugs.gentoo.org/649554
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-6.0.9999.ebuild5
-rw-r--r--dev-python/lit/lit-9999.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/lit/lit-6.0.9999.ebuild b/dev-python/lit/lit-6.0.9999.ebuild
index f167a14c32b7..d3e98d7342bd 100644
--- a/dev-python/lit/lit-6.0.9999.ebuild
+++ b/dev-python/lit/lit-6.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -36,5 +36,6 @@ src_unpack() {
}
python_test() {
- ./lit.py -vv tests || die
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
}
diff --git a/dev-python/lit/lit-9999.ebuild b/dev-python/lit/lit-9999.ebuild
index 43d292abf1de..74471d6212c7 100644
--- a/dev-python/lit/lit-9999.ebuild
+++ b/dev-python/lit/lit-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
@@ -35,5 +35,6 @@ src_unpack() {
}
python_test() {
- ./lit.py -vv tests || die
+ ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+ -vv tests || die
}