summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-24 22:45:21 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-24 22:45:21 -0400
commit23093edfc206367d290449f96f879d5bdd31e1d7 (patch)
treef0ea07feb8745e6da878f52bd4b8510462e969b0 /dev-python/llfuse/llfuse-0.41.ebuild
parentwww-apps/wordpress: version bump (diff)
downloadgentoo-23093edfc206367d290449f96f879d5bdd31e1d7.tar.gz
gentoo-23093edfc206367d290449f96f879d5bdd31e1d7.tar.bz2
gentoo-23093edfc206367d290449f96f879d5bdd31e1d7.zip
dev-python/llfuse: version bump
Diffstat (limited to 'dev-python/llfuse/llfuse-0.41.ebuild')
-rw-r--r--dev-python/llfuse/llfuse-0.41.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/llfuse/llfuse-0.41.ebuild b/dev-python/llfuse/llfuse-0.41.ebuild
new file mode 100644
index 000000000000..1b07f647a9c0
--- /dev/null
+++ b/dev-python/llfuse/llfuse-0.41.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=sys-fs/fuse-2.8.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # use system setuptools
+ sed -i '/use_setuptools/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}