summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-12 19:23:05 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-12 19:33:38 -0700
commit96ea897fc9d4fa242fbad3fff31a98a025293244 (patch)
treef10c739b46d2c994fb68be198e6101137289c03f /dev-python/llfuse/llfuse-1.3.6.ebuild
parentkde-apps/kio-extras: Cleanup vulnerable 19.12.3 (r0) (diff)
downloadgentoo-96ea897fc9d4fa242fbad3fff31a98a025293244.tar.gz
gentoo-96ea897fc9d4fa242fbad3fff31a98a025293244.tar.bz2
gentoo-96ea897fc9d4fa242fbad3fff31a98a025293244.zip
dev-python/llfuse-1.3.6: bump, EAPI=7, py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/llfuse/llfuse-1.3.6.ebuild')
-rw-r--r--dev-python/llfuse/llfuse-1.3.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/llfuse/llfuse-1.3.6.ebuild b/dev-python/llfuse/llfuse-1.3.6.ebuild
new file mode 100644
index 000000000000..1249f8ffda4b
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.3.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://github.com/python-llfuse/python-llfuse/ https://pypi.org/project/llfuse/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ sys-apps/attr
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}