summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-11-28 09:32:46 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-28 09:32:46 +0100
commit058c73e897e12f4726e000013e8fb5eef638aa52 (patch)
treecc9aaa1b8e5220a6a169902d3c6e297d231e47ed /dev-python/llvmlite
parentdev-ada/gnatcoll-db: stable (diff)
downloadgentoo-058c73e897e12f4726e000013e8fb5eef638aa52.tar.gz
gentoo-058c73e897e12f4726e000013e8fb5eef638aa52.tar.bz2
gentoo-058c73e897e12f4726e000013e8fb5eef638aa52.zip
dev-python/llvmlite: Bump to 0.26.0 (still no LLVM 7!)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.26.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index ad857c8c77d5..7ed794d6b466 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -2,3 +2,4 @@ DIST llvmlite-0.20.0.tar.gz 96753 BLAKE2B ec9cfa554f44162c0d6e755628603c9afd8564
DIST llvmlite-0.22.0.gh.tar.gz 156077 BLAKE2B 1b95a0636807fcf38955b32bd5c7c19784df2cc6708f23624c047f0e9caf4eb2fc26c7a1cb778d7cc7e42b8aeaee1ed43c92bcdaf7eb2e798c25f692b96b786a SHA512 633ec4d294dc246ebff5c7931e9bea86efa28323242411f3f54bc34c99085ebaef477b5bfd8224080790a12b188308ff9662c284b360e1a2939f4fe9b84a9458
DIST llvmlite-0.24.0.gh.tar.gz 169577 BLAKE2B 7fedf8b9ec49f537db27a77c5880fb3bb41d126c615e73a4fd503ff781dcd4745c4f708cccd31d9b5544609ab7821e8ef1299856ef13ec3912ad2341af12a3ce SHA512 14b8918f9f58a88596607e697212aa516a99c65f71257d22f09e6b735f517a38f11142a63bf2e8f117c6ceff97153a5e686fa322d62abd14000db7e9ae136900
DIST llvmlite-0.25.0.gh.tar.gz 173304 BLAKE2B 1376dee4b81343d22f218b0bc1c31f6dbd5eb1d8e4788a504626c1a653aa92500ab0685117c0d73c2a561e957dd930e411b4b128a85c9fddc712cee102690521 SHA512 a72b49db7720fa8a76647f9ad875b8e43e8738127a27fcb2646e28a543fb4e334ed690965e0c973e9d50b05fcbe4b9466f87c82936b3d49e61f774d0c7fd827e
+DIST llvmlite-0.26.0.gh.tar.gz 175536 BLAKE2B 6736e94c13974bb79bcda08ef58dd6d1e67d07a0173b5f2ab1b2fcf9a6e72b2a0b8737da5598023fa0c6db85cfd84f2d429f6077e1342a15b500376addd03c69 SHA512 e6bf76b209f44624fe21551971d422bbee6a6dcdfbd2c42607904be32db1b94cfcb185e70198fced5deadd938208d66d94eed4cea31726ae7f4779d58b57eb48
diff --git a/dev-python/llvmlite/llvmlite-0.26.0.ebuild b/dev-python/llvmlite/llvmlite-0.26.0.ebuild
new file mode 100644
index 000000000000..64fcac011116
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.26.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=6
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-devel/llvm-6.0.0-r1:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${P/_/}
+
+PATCHES=(
+ "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
+)
+
+python_configure_all() {
+ # upstream's build system is just horrible, and they ignored the PR
+ # fixing it, so let's build the shared lib properly using implicit
+ # make rules
+
+ export LDLIBS=$(llvm-config --libs all)
+ export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
+ export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
+
+ local files=( ffi/*.cpp )
+ emake -f - <<EOF
+ffi/libllvmlite.so: ${files[*]/.cpp/.o}
+ \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
+EOF
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}