summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-26 14:19:04 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-26 14:34:24 +0100
commit296d451dcc43e58e40d5001075e17f682b8c8b1a (patch)
tree158a478a55833c4a2ceab54c2c53910f1903d93c /dev-python/llvmlite
parentdev-python/distributed: Drop py3.4 due to deps, cleanup (diff)
downloadgentoo-296d451dcc43e58e40d5001075e17f682b8c8b1a.tar.gz
gentoo-296d451dcc43e58e40d5001075e17f682b8c8b1a.tar.bz2
gentoo-296d451dcc43e58e40d5001075e17f682b8c8b1a.zip
dev-python/llvmlite: Bump to 0.27.0rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.27.0_rc1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 7ed794d6b466..a5ba0573bb04 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -3,3 +3,4 @@ DIST llvmlite-0.22.0.gh.tar.gz 156077 BLAKE2B 1b95a0636807fcf38955b32bd5c7c19784
DIST llvmlite-0.24.0.gh.tar.gz 169577 BLAKE2B 7fedf8b9ec49f537db27a77c5880fb3bb41d126c615e73a4fd503ff781dcd4745c4f708cccd31d9b5544609ab7821e8ef1299856ef13ec3912ad2341af12a3ce SHA512 14b8918f9f58a88596607e697212aa516a99c65f71257d22f09e6b735f517a38f11142a63bf2e8f117c6ceff97153a5e686fa322d62abd14000db7e9ae136900
DIST llvmlite-0.25.0.gh.tar.gz 173304 BLAKE2B 1376dee4b81343d22f218b0bc1c31f6dbd5eb1d8e4788a504626c1a653aa92500ab0685117c0d73c2a561e957dd930e411b4b128a85c9fddc712cee102690521 SHA512 a72b49db7720fa8a76647f9ad875b8e43e8738127a27fcb2646e28a543fb4e334ed690965e0c973e9d50b05fcbe4b9466f87c82936b3d49e61f774d0c7fd827e
DIST llvmlite-0.26.0.gh.tar.gz 175536 BLAKE2B 6736e94c13974bb79bcda08ef58dd6d1e67d07a0173b5f2ab1b2fcf9a6e72b2a0b8737da5598023fa0c6db85cfd84f2d429f6077e1342a15b500376addd03c69 SHA512 e6bf76b209f44624fe21551971d422bbee6a6dcdfbd2c42607904be32db1b94cfcb185e70198fced5deadd938208d66d94eed4cea31726ae7f4779d58b57eb48
+DIST llvmlite-0.27.0rc1.gh.tar.gz 185944 BLAKE2B 1df9cd81ea84f8f46d5a0714cf2204a60c807dfdbe159b15c1f68a4de7aefde1ab61e90cbc175983ed252a678538828e0e7ce1c263274f7d49644e515c8dc3c5 SHA512 edab1411f505943a3bd0d9ab7eb90644978b8d3db7c405ba3e2c8d2e47d80fd1bf47028f7516c6799885ac594f4b72b814e1b7543374d4c97eda5e71d87bbedd
diff --git a/dev-python/llvmlite/llvmlite-0.27.0_rc1.ebuild b/dev-python/llvmlite/llvmlite-0.27.0_rc1.ebuild
new file mode 100644
index 000000000000..8b4612bd0774
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.27.0_rc1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=7
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${P/_/}
+
+PATCHES=(
+ "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
+)
+
+python_configure_all() {
+ # upstream's build system is just horrible, and they ignored the PR
+ # fixing it, so let's build the shared lib properly using implicit
+ # make rules
+
+ export LDLIBS=$(llvm-config --libs all)
+ export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
+ export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
+
+ local files=( ffi/*.cpp )
+ emake -f - <<EOF
+ffi/libllvmlite.so: ${files[*]/.cpp/.o}
+ \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
+EOF
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}