summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-02 09:25:54 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-09 21:02:23 +0200
commit42a477dc49d2a276b1b1d681abef745546c80b91 (patch)
tree676b3e3ed3f9c0ea7af3c581cacae342de81613a /dev-python/llvmlite
parentdev-util/include-what-you-use: Remove 5.0 (diff)
downloadgentoo-42a477dc49d2a276b1b1d681abef745546c80b91.tar.gz
gentoo-42a477dc49d2a276b1b1d681abef745546c80b91.tar.bz2
gentoo-42a477dc49d2a276b1b1d681abef745546c80b91.zip
dev-python/llvmlite: Remove 0.22.0 (for LLVM 5)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.22.0.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 6f4b1d7fa390..2091028e0609 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,4 +1,3 @@
-DIST llvmlite-0.22.0.gh.tar.gz 156077 BLAKE2B 1b95a0636807fcf38955b32bd5c7c19784df2cc6708f23624c047f0e9caf4eb2fc26c7a1cb778d7cc7e42b8aeaee1ed43c92bcdaf7eb2e798c25f692b96b786a SHA512 633ec4d294dc246ebff5c7931e9bea86efa28323242411f3f54bc34c99085ebaef477b5bfd8224080790a12b188308ff9662c284b360e1a2939f4fe9b84a9458
DIST llvmlite-0.26.0.gh.tar.gz 175536 BLAKE2B 6736e94c13974bb79bcda08ef58dd6d1e67d07a0173b5f2ab1b2fcf9a6e72b2a0b8737da5598023fa0c6db85cfd84f2d429f6077e1342a15b500376addd03c69 SHA512 e6bf76b209f44624fe21551971d422bbee6a6dcdfbd2c42607904be32db1b94cfcb185e70198fced5deadd938208d66d94eed4cea31726ae7f4779d58b57eb48
DIST llvmlite-0.28.0.gh.tar.gz 191141 BLAKE2B 23c86c28311a4e8c7f9c209a7ed7816ad5002c26f9fda7a47cf2b54c4578db28ed0781b54a716726db8a7c1abce79a79a99c3f5bf4be2a61d547eb74d06cb507 SHA512 c00c767c80a507975a055088ca4328766c992e7267219dea54376daf5eb11397532b243352976d3569185149007650d5e94839b61aa55502e1991f72b1ba492a
DIST llvmlite-0.29.0.gh.tar.gz 196507 BLAKE2B d4870ca042d446857b7409c0c50c370458747ee744c24611e88da4bc8780c26125b2e8db3db7fe9d4f553f9aae5769b62effe1ac94cfaf234bab54d43c8086e9 SHA512 8735b46b1a3053b89306bf6e05c8c6c375d15371d33635f1d27e5533d7a78a85f773e04b7ed8d39ebab40a892c374839e1324665d81459cb797f760d6d2c81d1
diff --git a/dev-python/llvmlite/llvmlite-0.22.0.ebuild b/dev-python/llvmlite/llvmlite-0.22.0.ebuild
deleted file mode 100644
index 7a2336c7b604..000000000000
--- a/dev-python/llvmlite/llvmlite-0.22.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="http://llvmlite.pydata.org/"
-# upstream slacks in making pypi releases
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-LLVM_MAX_SLOT=5
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
- virtual/python-enum34[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-PATCHES=(
- "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
-)
-
-python_prepare_all() {
- # disable -flto, we do not force it against user's wishes
- # add -fPIC, needed to link against shared libraries
- # plus use those vars to force our CXXFLAGS/LDFLAGS in...
- export CXX_FLTO_FLAGS="${CXXFLAGS} -fPIC"
- export LD_FLTO_FLAGS="${LDFLAGS} -fPIC"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}