summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-07 07:09:38 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-07 07:31:43 +0200
commit4af57e212134c59874813b9f58176b65290782ec (patch)
tree9e5be324abb5724f2906a8671432c273b219be1f /dev-python/llvmlite
parentapp-i18n/*fcitx*: Delete old versions. (diff)
downloadgentoo-4af57e212134c59874813b9f58176b65290782ec.tar.gz
gentoo-4af57e212134c59874813b9f58176b65290782ec.tar.bz2
gentoo-4af57e212134c59874813b9f58176b65290782ec.zip
dev-python/llvmlite: Bump to 0.24.0
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.24.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 7c564533ece1..35c7be317e92 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -4,3 +4,4 @@ DIST llvmlite-0.21.0.tar.gz 96462 BLAKE2B 8458037ca49c2c7035cc65539c1dc933f26c69
DIST llvmlite-0.22.0.gh.tar.gz 156077 BLAKE2B 1b95a0636807fcf38955b32bd5c7c19784df2cc6708f23624c047f0e9caf4eb2fc26c7a1cb778d7cc7e42b8aeaee1ed43c92bcdaf7eb2e798c25f692b96b786a SHA512 633ec4d294dc246ebff5c7931e9bea86efa28323242411f3f54bc34c99085ebaef477b5bfd8224080790a12b188308ff9662c284b360e1a2939f4fe9b84a9458
DIST llvmlite-0.23.0.gh.tar.gz 167384 BLAKE2B f0f64f389004b8c07b40ad42bfe2aa10b06769c59c6ca84fd89c5c38e0f453bc079d435418fe19bdd5b97b9cac698eae5c537417bee181485390745b8d319fc8 SHA512 e4fa0096d73351a73b0509ca312dd79f8b4a50eeae03d7491761c68738e1c4f8204be1c2eefad71e10edfbcaef062dafa4270029e1b254febc580016aff2d3b9
DIST llvmlite-0.23.2.gh.tar.gz 168206 BLAKE2B 8ed2c2a84cdad80bcdba95e4e2d0f15b8c0a6cab2114b4c5f6eb32a303e29a9185629cf692acaec1455ac059227a755f621147397ece59343347434572186dff SHA512 f5f0a27ff7d523d3ce9c183b60db1106ee89f2650dfaac9e745414dbf91e14cf3ba9056e694148d07f4caab4b9f9fdd1806aa67f580de1b8b317b906d2c4fe65
+DIST llvmlite-0.24.0.gh.tar.gz 169577 BLAKE2B 7fedf8b9ec49f537db27a77c5880fb3bb41d126c615e73a4fd503ff781dcd4745c4f708cccd31d9b5544609ab7821e8ef1299856ef13ec3912ad2341af12a3ce SHA512 14b8918f9f58a88596607e697212aa516a99c65f71257d22f09e6b735f517a38f11142a63bf2e8f117c6ceff97153a5e686fa322d62abd14000db7e9ae136900
diff --git a/dev-python/llvmlite/llvmlite-0.24.0.ebuild b/dev-python/llvmlite/llvmlite-0.24.0.ebuild
new file mode 100644
index 000000000000..e7d50fc0b39f
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.24.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+# upstream slacks in making pypi releases
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=6
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-devel/llvm-6.0.0-r1:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PATCHES=(
+ "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
+)
+
+python_prepare_all() {
+ # disable -flto, we do not force it against user's wishes
+ # add -fPIC, needed to link against shared libraries
+ # plus use those vars to force our CXXFLAGS/LDFLAGS in...
+ export CXX_FLTO_FLAGS="${CXXFLAGS} -fPIC"
+ export LD_FLTO_FLAGS="${LDFLAGS} -fPIC"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}