summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-22 14:42:13 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-22 14:47:33 +0200
commitfe120d600ed73c45a0d2221041e9c5b2aa704aef (patch)
treed24108df1ec243ea774c88d63e1ed3657dfde02d /dev-python/llvmlite
parentdev-libs/libgit2: Bump to 0.28.2 (diff)
downloadgentoo-fe120d600ed73c45a0d2221041e9c5b2aa704aef.tar.gz
gentoo-fe120d600ed73c45a0d2221041e9c5b2aa704aef.tar.bz2
gentoo-fe120d600ed73c45a0d2221041e9c5b2aa704aef.zip
dev-python/llvmlite: Bump to 0.29.0rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest1
-rw-r--r--dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index 4b9e08d38901..40fd882b7290 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -4,3 +4,4 @@ DIST llvmlite-0.26.0.gh.tar.gz 175536 BLAKE2B 6736e94c13974bb79bcda08ef58dd6d1e6
DIST llvmlite-0.27.0.gh.tar.gz 186891 BLAKE2B c7175beeb5c45b6fda62b78b23352d1c22111a37e7fdb89897409c6ab245dab23aa4f799fd5add1bf2199e8f6783d6094101aa29c4afefa2a3dbd48d735b418a SHA512 6c3230f23fec53ddff077c885bc0da4a773049d0226817142e2b7ded9fe6a665dd5cf8c6468101b342ef8e3b394bf2078cf93fc513e46fe451cd75755111448b
DIST llvmlite-0.27.1.gh.tar.gz 186904 BLAKE2B ee3af4b3ec03799ea6e643e0ee0a793537c46427d239fb3a26abf4a719b68432f403367321345c30a95758ce1bce411495bc48273dbf2452a872a1edd67dc9a4 SHA512 365ffd95050a39269d9f806d3969657437111b8e999db6cf03d0d99fc5bcc024dbc08f1d379745572317f8d4384d7f86095216674695c34f463a0b9bf48a8be7
DIST llvmlite-0.28.0.gh.tar.gz 191141 BLAKE2B 23c86c28311a4e8c7f9c209a7ed7816ad5002c26f9fda7a47cf2b54c4578db28ed0781b54a716726db8a7c1abce79a79a99c3f5bf4be2a61d547eb74d06cb507 SHA512 c00c767c80a507975a055088ca4328766c992e7267219dea54376daf5eb11397532b243352976d3569185149007650d5e94839b61aa55502e1991f72b1ba492a
+DIST llvmlite-0.29.0rc1.gh.tar.gz 196498 BLAKE2B 6db47948ac38bf61df7bf5eef60a29ac710d259b9b3fdcf8d9cb52239de85211969a34f707c155170e5b42d060e2d3e8616cf1b7720ebc808bddcc427a144bc9 SHA512 80f06584d52fe5947a06eec9ee88ba51c29847f53b4a2c9b21c660478c9e3f873f80677ebcffe1678e327d1132170bdc97737c385823ca0cbbfa9d9f1158cc0a
diff --git a/dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild b/dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild
new file mode 100644
index 000000000000..98ff820616ca
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.29.0_rc1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=8
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${P/_/}
+
+PATCHES=(
+ "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
+)
+
+python_configure_all() {
+ # upstream's build system is just horrible, and they ignored the PR
+ # fixing it, so let's build the shared lib properly using implicit
+ # make rules
+
+ export LDLIBS=$(llvm-config --libs all)
+ export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
+ export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
+
+ local files=( ffi/*.cpp )
+ emake -f - <<EOF
+ffi/libllvmlite.so: ${files[*]/.cpp/.o}
+ \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
+EOF
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}