summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-07 12:38:35 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-07 12:45:24 +0200
commit474620d5b9d9ff06f5079c22df906b12b208434c (patch)
tree404a2386114f185fab8f6e1e1c5ee28513afec7b /dev-python/lmfit/lmfit-1.0.1.ebuild
parentdev-python/asteval: Needed by newer chemex (diff)
downloadgentoo-474620d5b9d9ff06f5079c22df906b12b208434c.tar.gz
gentoo-474620d5b9d9ff06f5079c22df906b12b208434c.tar.bz2
gentoo-474620d5b9d9ff06f5079c22df906b12b208434c.zip
dev-python/lmfit: Needed by newer chemex
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/lmfit/lmfit-1.0.1.ebuild')
-rw-r--r--dev-python/lmfit/lmfit-1.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/lmfit/lmfit-1.0.1.ebuild b/dev-python/lmfit/lmfit-1.0.1.ebuild
new file mode 100644
index 000000000000..3b27e1c92c05
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..8} )
+inherit distutils-r1
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ >=dev-python/asteval-0.9.16[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.2[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest