summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-08 09:24:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-08 09:43:57 +0100
commit1fd59aff689ddbddaa87822b902252998d35acc0 (patch)
treed6312a54eb6aff47e129d82205b464db024a3deb /dev-python/lmfit/lmfit-1.0.2.ebuild
parentdev-python/cwcwidth: Bump to 0.1.4 (diff)
downloadgentoo-1fd59aff689ddbddaa87822b902252998d35acc0.tar.gz
gentoo-1fd59aff689ddbddaa87822b902252998d35acc0.tar.bz2
gentoo-1fd59aff689ddbddaa87822b902252998d35acc0.zip
dev-python/lmfit: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lmfit/lmfit-1.0.2.ebuild')
-rw-r--r--dev-python/lmfit/lmfit-1.0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/lmfit/lmfit-1.0.2.ebuild b/dev-python/lmfit/lmfit-1.0.2.ebuild
new file mode 100644
index 000000000000..3be5d42ef10e
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/asteval-0.9.16[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # numpy warning mismatch
+ tests/test_confidence.py::test_confidence_warnings
+ tests/test_model.py::TestUserDefiniedModel::test_extra_param_issues_warning
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}