summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 13:19:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 13:32:05 +0200
commit1333edb42cf549d582f4c65b2a55f92d8b6ee6f8 (patch)
tree5466f2e4be1a6a69346059f0f454e252953ddbf2 /dev-python/lmfit/lmfit-1.1.0.ebuild
parentdev-python/latexcodec: Remove old (diff)
downloadgentoo-1333edb42cf549d582f4c65b2a55f92d8b6ee6f8.tar.gz
gentoo-1333edb42cf549d582f4c65b2a55f92d8b6ee6f8.tar.bz2
gentoo-1333edb42cf549d582f4c65b2a55f92d8b6ee6f8.zip
dev-python/lmfit: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lmfit/lmfit-1.1.0.ebuild')
-rw-r--r--dev-python/lmfit/lmfit-1.1.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/lmfit/lmfit-1.1.0.ebuild b/dev-python/lmfit/lmfit-1.1.0.ebuild
deleted file mode 100644
index 2638f31abd84..000000000000
--- a/dev-python/lmfit/lmfit-1.1.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=lmfit-py-${PV}
-DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
-HOMEPAGE="
- https://lmfit.github.io/lmfit-py/
- https://github.com/lmfit/lmfit-py/
- https://pypi.org/project/lmfit/
-"
-SRC_URI="
- https://github.com/lmfit/lmfit-py/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/asteval-0.9.28[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.6[${PYTHON_USEDEP}]
- >=dev-python/uncertainties-3.1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- tests/test_model.py::TestUserDefiniedModel::test_model_nan_policy
- )
-
- epytest -o addopts=
-}