summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-10-15 21:50:43 -0400
committerMike Gilbert <floppym@gentoo.org>2015-10-15 21:50:43 -0400
commit86e5533e18663f26a8f9af19b42169c818fc0c63 (patch)
treead36c1b45b92054d4db801eb1ad86ce03ee17d7c /dev-python/lockfile/lockfile-0.11.0-r1.ebuild
parentx11-misc/fireflies: 2.08 (diff)
downloadgentoo-86e5533e18663f26a8f9af19b42169c818fc0c63.tar.gz
gentoo-86e5533e18663f26a8f9af19b42169c818fc0c63.tar.bz2
gentoo-86e5533e18663f26a8f9af19b42169c818fc0c63.zip
dev-python/lockfile: Remove upper-bound on dev-python/pbr
Package-Manager: portage-2.2.23_p4
Diffstat (limited to 'dev-python/lockfile/lockfile-0.11.0-r1.ebuild')
-rw-r--r--dev-python/lockfile/lockfile-0.11.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/lockfile/lockfile-0.11.0-r1.ebuild b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..1979687a3a4e
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="https://launchpad.net/pylockfile https://pypi.python.org/pypi/lockfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ >dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
+
+python_prepare_all() {
+ rm requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ emake -C doc/source html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
+ nosetests || die "test_lockfile failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/.build/html/. )
+ distutils-r1_python_install_all
+}