summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-21 13:26:22 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-21 18:51:38 +0200
commit94a81d4c13160676cf61f100c00ec214d1f037be (patch)
treeb00a5b80d9d563451fd4b1f69c067bdb98e96b9c /dev-python/lockfile/lockfile-0.12.2-r1.ebuild
parentdev-python/fusil: EAPI 6 bump. (diff)
downloadgentoo-94a81d4c13160676cf61f100c00ec214d1f037be.tar.gz
gentoo-94a81d4c13160676cf61f100c00ec214d1f037be.tar.bz2
gentoo-94a81d4c13160676cf61f100c00ec214d1f037be.zip
dev-python/lockfile: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/lockfile/lockfile-0.12.2-r1.ebuild')
-rw-r--r--dev-python/lockfile/lockfile-0.12.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lockfile/lockfile-0.12.2-r1.ebuild b/dev-python/lockfile/lockfile-0.12.2-r1.ebuild
new file mode 100644
index 000000000000..27e49b9c0d32
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.12.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="https://launchpad.net/pylockfile https://pypi.python.org/pypi/lockfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ >dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
+
+python_compile_all() {
+ use doc && emake -C doc/source html
+}
+
+python_test() {
+ # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
+ nosetests --verbose || die "test_lockfile failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dodoc -r doc/source/.build/html
+ distutils-r1_python_install_all
+}