summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-08-05 11:03:14 +0200
committerSam James <sam@gentoo.org>2020-08-07 01:10:08 +0000
commitf917d1625394edad2dc197834d6ddc07d6b94d81 (patch)
tree1c91a1af255812076e09db4879422a5828a8dd02 /dev-python/lockfile/lockfile-0.12.2-r2.ebuild
parentdev-python/libcloud: fix missing mock test dep (diff)
downloadgentoo-f917d1625394edad2dc197834d6ddc07d6b94d81.tar.gz
gentoo-f917d1625394edad2dc197834d6ddc07d6b94d81.tar.bz2
gentoo-f917d1625394edad2dc197834d6ddc07d6b94d81.zip
dev-python/lockfile: port to py3.9
Use distutils_enable_{tests,sphinx} Package is deprecated. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/lockfile/lockfile-0.12.2-r2.ebuild')
-rw-r--r--dev-python/lockfile/lockfile-0.12.2-r2.ebuild28
1 files changed, 4 insertions, 24 deletions
diff --git a/dev-python/lockfile/lockfile-0.12.2-r2.ebuild b/dev-python/lockfile/lockfile-0.12.2-r2.ebuild
index 715cb4795405..9cab46e092f7 100644
--- a/dev-python/lockfile/lockfile-0.12.2-r2.ebuild
+++ b/dev-python/lockfile/lockfile-0.12.2-r2.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+)"
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
inherit distutils-r1
@@ -15,27 +14,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DEPEND="
- >dev-python/pbr-1.8[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
+DEPEND=">dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
-
-python_compile_all() {
- use doc && emake -C doc/source html
-}
-
-python_test() {
- # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
- nosetests --verbose || die "test_lockfile failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && dodoc -r doc/source/.build/html
- distutils-r1_python_install_all
-}
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source --no-autodoc