summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-14 19:45:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-14 19:45:35 +0200
commit6492c93f4b2f86b053b39fc986b3a0646be7b7f1 (patch)
treeda3e3160f88b98bb6b3a387dac3cdfb3bc84915d /dev-python/logfury
parentprofiles: Mask x11-misc/xnee for removal (diff)
downloadgentoo-6492c93f4b2f86b053b39fc986b3a0646be7b7f1.tar.gz
gentoo-6492c93f4b2f86b053b39fc986b3a0646be7b7f1.tar.bz2
gentoo-6492c93f4b2f86b053b39fc986b3a0646be7b7f1.zip
dev-python/logfury: PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/logfury')
-rw-r--r--dev-python/logfury/logfury-1.0.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/logfury/logfury-1.0.1-r1.ebuild b/dev-python/logfury/logfury-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..f73d9cb6f78f
--- /dev/null
+++ b/dev-python/logfury/logfury-1.0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Boilerplate library for logging method calls"
+HOMEPAGE="
+ https://github.com/reef-technologies/logfury
+ https://pypi.org/project/logfury/"
+SRC_URI="
+ https://github.com/reef-technologies/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pin for old Pythons (sic!)
+ sed -i -e '/setuptools_scm/d' setup.py || die
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}