summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-08 11:08:17 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-08 13:35:00 +0100
commitc1e7cd7d73a20d21e665797ac0531c7748128dad (patch)
treec72b8e59a08511d2eff6bba3cff4bea9c51f154c /dev-python/loky/loky-2.9.0.ebuild
parentx11-wm/xpra: Bump to 4.1.1, drop old 4.1 (diff)
downloadgentoo-c1e7cd7d73a20d21e665797ac0531c7748128dad.tar.gz
gentoo-c1e7cd7d73a20d21e665797ac0531c7748128dad.tar.bz2
gentoo-c1e7cd7d73a20d21e665797ac0531c7748128dad.zip
dev-python/loky: Fix tests with newer CPython
Fix test failure with newer versions of CPython due to incorrect loading of libc via ctypes. Closes: https://bugs.gentoo.org/774789 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/loky/loky-2.9.0.ebuild')
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
index 70165402b043..a4096ef4abeb 100644
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ b/dev-python/loky/loky-2.9.0.ebuild
@@ -25,6 +25,10 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${P}-libc.patch
+)
+
python_test() {
local args=(
# docker, seriously?
@@ -34,5 +38,5 @@ python_test() {
--skip-high-memory
)
- pytest -vv "${args[@]}" || die "Tests failed on ${EPYTHON}"
+ epytest "${args[@]}"
}