summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-04-19 12:29:38 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-04-20 09:57:55 -0700
commita1ea59538c79d2416a19c06b7783939bae3dd639 (patch)
tree0706328011d40e0fb2759bfa5f12ed12a7020442 /dev-python/looseversion/looseversion-1.1.2.ebuild
parentsys-apps/openrc: drop 0.47 (diff)
downloadgentoo-a1ea59538c79d2416a19c06b7783939bae3dd639.tar.gz
gentoo-a1ea59538c79d2416a19c06b7783939bae3dd639.tar.bz2
gentoo-a1ea59538c79d2416a19c06b7783939bae3dd639.zip
dev-python/looseversion: new package, add 1.1.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/looseversion/looseversion-1.1.2.ebuild')
-rw-r--r--dev-python/looseversion/looseversion-1.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/looseversion/looseversion-1.1.2.ebuild b/dev-python/looseversion/looseversion-1.1.2.ebuild
new file mode 100644
index 000000000000..064ff7ee6400
--- /dev/null
+++ b/dev-python/looseversion/looseversion-1.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+inherit pypi distutils-r1
+
+DESCRIPTION="A backwards/forwards-compatible fork of distutils.version.LooseVersion"
+HOMEPAGE="
+ https://pypi.org/project/looseversion/
+ https://github.com/effigies/looseversion
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}