summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/lp_solve/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/lp_solve/files')
-rw-r--r--dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch b/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch
new file mode 100644
index 000000000000..a28b8179d261
--- /dev/null
+++ b/dev-python/lp_solve/files/lp_solve-5.5.2.0-setup.patch
@@ -0,0 +1,50 @@
+--- setup.py.orig 2012-01-07 20:27:45.072840503 +0000
++++ setup.py 2012-01-07 20:24:22.127570128 +0000
+@@ -1,26 +1,25 @@
+ from distutils.core import setup, Extension
+ from os import getenv
+ import sys
+-import os
+-p = sys.prefix
+-NUMPYPATH = '.'
+-if os.path.isdir(p + '/include/numpy'):
+- NUMPY = 'NUMPY'
+-elif os.path.isdir(p + '/Lib/site-packages/numpy/core/include/numpy'):
+- NUMPY = 'NUMPY'
+- NUMPYPATH = p + '/Lib/site-packages/numpy/core/include'
+-else:
++import os, os.path
++
++try:
++ import numpy
++ NUMPY = 'NUMPY'
++ NUMPYPATH = numpy.get_include()
++except:
+ NUMPY = 'NONUMPY'
+-print 'numpy: ' + NUMPY
++ NUMPYPATH = '.'
++
+ windir = getenv('windir')
+ if windir == None:
+ WIN32 = 'NOWIN32'
+- LPSOLVE55 = '../../lpsolve55/bin/ux32'
++ LPSOLVEINC = os.path.join(sys.prefix,'include','lpsolve')
+ else:
+ WIN32 = 'WIN32'
+ LPSOLVE55 = '../../lpsolve55/bin/win32'
+ setup (name = "lpsolve55",
+- version = "5.5.0.9",
++ version = "5.5.2.0",
+ description = "Linear Program Solver, Interface to lpsolve",
+ author = "Peter Notebaert",
+ author_email = "lpsolve@peno.be",
+@@ -29,8 +28,7 @@
+ ext_modules = [Extension("lpsolve55",
+ ["lpsolve.c", "hash.c", "pythonmod.c"],
+ define_macros=[('PYTHON', '1'), (WIN32, '1'), ('NODEBUG', '1'), ('DINLINE', 'static'), (NUMPY, '1'), ('_CRT_SECURE_NO_WARNINGS', '1')],
+- include_dirs=['../..', NUMPYPATH],
+- library_dirs=[LPSOLVE55],
++ include_dirs=[LPSOLVEINC, NUMPYPATH],
+ libraries = ["lpsolve55"])
+ ]
+ )