summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-23 09:21:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-23 09:25:37 +0200
commit769519be3b1db7249ad32034d6adb9bf0bc5fbe0 (patch)
treeca135c4efe580664a707115f23ca18024e048b14 /dev-python/lunr/lunr-0.6.0.ebuild
parentdev-python/watchdog: Bump to 2.0.3 (diff)
downloadgentoo-769519be3b1db7249ad32034d6adb9bf0bc5fbe0.tar.gz
gentoo-769519be3b1db7249ad32034d6adb9bf0bc5fbe0.tar.bz2
gentoo-769519be3b1db7249ad32034d6adb9bf0bc5fbe0.zip
dev-python/lunr: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lunr/lunr-0.6.0.ebuild')
-rw-r--r--dev-python/lunr/lunr-0.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/lunr/lunr-0.6.0.ebuild b/dev-python/lunr/lunr-0.6.0.ebuild
new file mode 100644
index 000000000000..665f1c777289
--- /dev/null
+++ b/dev-python/lunr/lunr-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DOCS_BUILDER="mkdocs"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="A Python implementation of Lunr.js"
+HOMEPAGE="https://github.com/yeraydiazdiaz/lunr.py"
+SRC_URI="https://github.com/yeraydiazdiaz/lunr.py/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.py-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nltk[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --ignore tests/acceptance_tests
+}