summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 16:24:39 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 16:24:39 +0200
commit90ba1563a20923d2924805c941a7d4b5a8f92942 (patch)
treeae505806513adc1cc1d5e26a4f9f13bbb4da3693 /dev-python/lz4/lz4-0.7.0.ebuild
parentmedia-gfx/shotwell: QA fix Add missing quotes (diff)
downloadgentoo-90ba1563a20923d2924805c941a7d4b5a8f92942.tar.gz
gentoo-90ba1563a20923d2924805c941a7d4b5a8f92942.tar.bz2
gentoo-90ba1563a20923d2924805c941a7d4b5a8f92942.zip
dev-python/lz4: Fix installation without dev-python/nose installed
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=562448 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/lz4/lz4-0.7.0.ebuild')
-rw-r--r--dev-python/lz4/lz4-0.7.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-0.7.0.ebuild b/dev-python/lz4/lz4-0.7.0.ebuild
index 5e4d293b9f0e..c706375fe60e 100644
--- a/dev-python/lz4/lz4-0.7.0.ebuild
+++ b/dev-python/lz4/lz4-0.7.0.ebuild
@@ -20,3 +20,10 @@ RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
# Tests still excluded by upstream
+
+python_prepare_all() {
+ sed \
+ -e '/nose/s:setup_requires:test_requires:g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}